Uploaded image for project: 'Qt Installer Framework'
  1. Qt Installer Framework
  2. QTIFW-1117

Installer no longer working behind a proxy

    XMLWordPrintable

    Details

      Description

      All installers (from [1]) since qt-creator-opensource-linux-x86_64-4.6.0-rc1_1936.run from Feb. 15th or newer no longer work with a proxy, even when starting it with --no-proxy. It hangs with the message "Performing license pre-conditions check..." (see QTBUG-65143 and QTBUG-66463 ), and after that times out "Network connection not found. You can still continue installation." is shown and the installer can continue. The previous version ...-4.6.0-rc1_1935.run worked fine (and does not know the --no-proxy options). Was the installer built with a still buggy QtInstallerFramework?

      1: https://download.qt.io/snapshots/qtcreator/4.6/

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              kamartti Katja Marttila
              Reporter:
              tmmz Thomas Otto
              Votes:
              2 Vote for this issue
              Watchers:
              11 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes