Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-8099

qtcreator_process_stub "eats" unicode characters

    XMLWordPrintable

Details

    • Bug
    • Status: Reported
    • P2: Important
    • Resolution: Unresolved
    • Qt Creator 2.5.2
    • None
    • All Other Issues
    • None
    • Windows 7 Pro, Ubuntu 12.04, Mac OS X 10.7

    Description

      When you use QDebug to output unicode text (characters) to the console and run console application under QtCreator, qtcreator_process_stub "eats" unicode characters. See attached imiges. This happens on all desktop platforms (Windows, Linux, Mac OS).

      • Linux and Mac OS X. If you run this console app directly in terminal, unicode works OK!
      • Windows. Unicode is not working in console app at all. To fix this you must call Win32 API function SetConsoleOutputCP(CP_UTF8).

      This question was discussed in forum thread:
      https://qt-project.org/forums/viewthread/21089/#100766

      Attachments

        1. Console UNICODE output1.PNG
          49 kB
          Algirdas
        2. Console UNICODE output2.PNG
          49 kB
          Algirdas
        3. Screenshot.png
          134 kB
          Algirdas
        4. Untitled.png
          106 kB
          Algirdas

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

              portale Alessandro Portale
              algirdasss Algirdas
              Votes:
              4 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

                Created:
                Updated:

                Gerrit Reviews

                  There are no open Gerrit changes